<!DOCTYPE html>
<html lang="en">

<head>
	<link href="https://fonts.googleapis.com/css2?family=Nunito:wght@300;400;700&display=swap" rel="stylesheet">
	<link rel="stylesheet" href="/upd/20210419.143709.104540/static/css/chunk-common.css">
	<link rel="stylesheet" href="/upd/20210419.143709.10204/static/css/video.css">

	<title></title>
	<meta name="viewport" content="width=1024, initial-scale=1, user-scalable=yes">
	<meta name="description" content="">
	<meta name="keywords" content="">
	<meta name="robots" content="ALL,INDEX,FOLLOW">
	<meta name="revisit-after" content="2 days">
	<meta name="RATING" content="RTA-5042-1996-1400-1577-RTA" />
	<meta name="fragment" content="!">
	<meta http-equiv="content-type" content="text/html; charset=utf-8">
	<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1.0, user-scalable=0">
	<meta name="msapplication-TileColor" content="#ffffff">
	<meta name="msapplication-TileImage" content="/static/images/favicons/ms-icon-144x144.png">
	<meta name="theme-color" content="#ffffff">
	<meta property="og:title" content="" />
	<meta property="og:description" content="" />

	<link rel="apple-touch-icon" sizes="57x57" href="/static/images/favicons/apple-icon-57x57.png">
	<link rel="apple-touch-icon" sizes="60x60" href="/static/images/favicons/apple-icon-60x60.png">
	<link rel="apple-touch-icon" sizes="72x72" href="/static/images/favicons/apple-icon-72x72.png">
	<link rel="apple-touch-icon" sizes="76x76" href="/static/images/favicons/apple-icon-76x76.png">
	<link rel="apple-touch-icon" sizes="114x114" href="/static/images/favicons/apple-icon-114x114.png">
	<link rel="apple-touch-icon" sizes="120x120" href="/static/images/favicons/apple-icon-120x120.png">
	<link rel="apple-touch-icon" sizes="144x144" href="/static/images/favicons/apple-icon-144x144.png">
	<link rel="apple-touch-icon" sizes="152x152" href="/static/images/favicons/apple-icon-152x152.png">
	<link rel="apple-touch-icon" sizes="180x180" href="/static/images/favicons/apple-icon-180x180.png">
	<link rel="icon" type="image/png" sizes="192x192" href="/static/images/favicons/android-icon-192x192.png">
	<link rel="icon" type="image/png" sizes="32x32" href="/static/images/favicons/favicon-32x32.png">
	<link rel="icon" type="image/png" sizes="96x96" href="/static/images/favicons/favicon-96x96.png">
	<link rel="icon" type="image/png" sizes="16x16" href="/static/images/favicons/favicon-16x16.png">
	<link rel="manifest" href="/static/images/favicons/manifest.json">

	<link rel="dns-prefetch" href="//www.googletagmanager.com">
	<link rel="dns-prefetch" href="//mc.yandex.ru">
	<link rel="canonical" href="https://hdzog.com/videos/841383/satine-spark-debut-with-boyfriend-christian/">

	<!-- Google Tag Manager -->
	<script>
		var gtinit = function() {
			! function(e, t, n, a, g) {
				e[a] = e[a] || [], e[a].push({
					"gtm.start": (new Date).getTime(),
					event: "gtm.js"
				});
				var i = t.getElementsByTagName(n)[0],
					r = t.createElement(n);
				r.async = !0, r.src = "https://www.googletagmanager.com/gtm.js?id=GTM-MVMB4DG", i.parentNode.insertBefore(
					r, i)
			}(window, document, "script", "dataLayer"),
			function(e, t, n, a, g) {
				e[a] = e[a] || [], e[a].push({
					"gtm.start": (new Date).getTime(),
					event: "gtm.js"
				});
				var i = t.getElementsByTagName(n)[0],
					r = t.createElement(n);
				r.async = !0, r.src = "//www.googletagmanager.com/gtm.js?id=GTM-PGXHKV", i.parentNode.insertBefore(r, i)
			}(window, document, "script", "dataLayer")
		}; - 1 == window.navigator.userAgent.indexOf("Lighthouse") ? gtinit() : setTimeout(function() {
			gtinit()
		}, 5e3);
	</script>
	<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-PGXHKV" height="0" width="0"
			style="display:none;visibility:hidden"></iframe></noscript>
	<!-- End Google Tag Manager -->

	<!-- /Yandex.Metrika counter -->
	<noscript>
		<div><img src="https://mc.yandex.ru/watch/49315045" style="position:absolute; left:-9999px;" alt=""></div>
	</noscript>
	<noscript>
		<div><img src="https://mc.yandex.ru/watch/33008259" style="position:absolute; left:-9999px;" alt=""></div>
	</noscript>
	<!-- /Yandex.Metrika counter -->

	<script>
		window.constants = {"lang_version":1605624294,"country_code":"us","host_root":"hdzog.com","project_name":"hdzog.com","query":{"video_id":"841383","video_dir":"satine-spark-debut-with-boyfriend-christian","lifetime":"86400"},"warmup_chance":1};
		window.isDesktop = true;
		window.ad_tags = "";
	</script>
	<script>
		window.EoCR4 = {1:'cdn69508963.ahacdn.me/c1/videos',3:'cdn69508963.ahacdn.me/c2/videos',5:'cdn12694176.ahacdn.me/c3/videos'};
	</script>
	<script>
 document.addEventListener('loadHardlink', function(event) {
  	adver('hardlink', {
      onLoad: function(data) {
        event.detail.hardlinkLoader(data);
      }   
    });
  }) 
</script>
	
	<script src="/upd/20210419.143246.13998/assets/previewl1b.20190620.1.js" async></script>
</head>

<body>
	<script>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</script>
<script src="/afon/rass7.4.13.1a6312407602439ceb86de11302999db.js"></script>

	<link rel="manifest" href="/manifest.json">
<script>
var isALOHA = ['qqqporn.com', 'pornsos.com', 'alohatube.com', 'alohamature.com'].some(function(element) { return document.referrer.indexOf(element) !== -1; });
var pbtn = !(adver.cookie.get('source') === '15172' && (isALOHA || document.referrer === '' || document.referrer === location.href));

var mz = adver.utmToSession.get('plimit') == '1';
var seekIsActive = adver.qs.seek_time;
var ignorePush = !(!seekIsActive && pbtn && adver.qs.promo !== '25435' && adver.qs.promo !== '11914' && adver.qs.promo !== '31134' && location.pathname.indexOf('/embed/') == -1);
var ignoreCalendar = !(!seekIsActive && !mz && !adver.isBravo && !adver.isPCO && pbtn && adver.qs.promo !== '31134' && adver.qs.promo !== '10268');

var __adm_override = {
  push: {
   	config: {
      serviceWorkerPath: '/ps/service-worker.js',
      tube: 'hdzog',
      remoteSubOnDenied: true,
      sub: document.cookie.split('; ').reduce(function (hash, el) { var parts = el.split('='); return hash[parts[0]] = parts[1], hash; }, {})['source'] || 0,
      remoteSub: {
        skip: ['promo=10268', 'promo=1013', 'promo=1085'],
        poperText: {
          blocked: {
            'en': {
              title: 'Want to remove ads?',
              buttonAction: 'Remove',
              buttonDecline: 'Later'
            },
            'ru': {
              title: 'Хотите убрать рекламу?',
              buttonAction: 'Убрать',
              buttonDecline: 'Позже'
            },
            "de": {
              title: 'Möchten Sie Anzeigen entfernen?',
              buttonAction: 'Löschen',
              buttonDecline: 'Später'
            },
            "fr": {
              title: 'Voulez-vous supprimer les annonces?',
              buttonAction: 'Retirer',
              buttonDecline: 'Plus tard'
            },
            "it": {
              title: 'Vuoi rimuovere gli annunci?',
              buttonAction: 'Rimuovere',
              buttonDecline: 'Dopo'
            },
            "es": {
              title: '¿Quieres eliminar anuncios?',
              buttonAction: 'Quitar',
              buttonDecline: 'Luego'
            },
            "ja": {
              title: '広告を削除しますか？',
              buttonAction: '削除する',
              buttonDecline: '後'
            },
            "hi": {
              title: "विज्ञापन निकालना चाहते हैं?",
              buttonAction: "हटाना",
              buttonDecline: "बाद में"
            }
          }
        }
      }
    },
    ignore: [{
      vars: {
        ignorePush: true
      }
    }]
  },
  inpage: [{
    bind: [{
      platforms: ['mobile']
    }]
  }],
  calendar: [{
    config: {
      cappingTime: 21600
    },
    ignore: [{
      vars: {
        ignoreCalendar: true
      }
    }]
  }]
};

if (!adver.isBravo && adver.qs.promo !== '31134') { 
  var adManager = document.createElement('script');
  adManager.src = "https://cst.cstwpush.com/static/adManager.js";
  adManager.setAttribute('data-admpid', 688);
  adManager.setAttribute('async', '');
  document.head.appendChild(adManager);
}

/*    if (
    !seekIsActive 
    && !mz 
    && !adver.isBravo 
    && !adver.isPCO 
    && pbtn 
    && adver.qs.promo !== '31134' 
    && adver.qs.promo !== '10268') 
  {
      (function(name, conf, src, event) {
		if(location.toString().indexOf('/embed/') != -1){return}
          try {
              var event = new Event(name);
              window.addEventListener(name, function(e) {
                  typeof e._init === 'function' && e._init(conf)
              }, false);
              document.querySelector('head,body').appendChild(Object.assign(document.createElement('script'), {
                  src: src
              }))
          } catch (e) {}
      })('__cp-initev', {
          tcid: 2000006,
          cappingTime: 21600
      }, 'https://sw.swwpush.com/npc/sdk/wpu/csub.js')
  } */

</script>
<script>
var cbIsInited = false;
function advercb() {
  cbIsInited = true;


  if (
    !seekIsActive 
    && pbtn 
    && location.pathname.indexOf('/embed/') == -1 
    && adver.qs.promo !== '25435'
  	&& adver.qs.promo !== '11914' 
    && adver.qs.promo !== '31134' 
    && adver.cookie.get("source") >= 1000) 
  {
    var swm = document.createElement('script');
    swm.src = "/sw.js";
    swm.type = "application/javascript";
    document.head.appendChild(swm);
  }
}
  
  
if (window.adver !== void 0 && !cbIsInited) advercb();

function runDownloadBanner(nodeId) {
  adver('invideo', {
    div: nodeId,
    force: true
  });
}


document.addEventListener('DOMContentLoaded', function () {
  var isFirefox = adver.detect().browser.name === 'Firefox';

  if (isFirefox && adver.isAdblock()) {
    document.addEventListener('click', function (e) {
      if (e.button === 2) e.stopImmediatePropagation();
    })
  }
});
  
  /*Auto play and seek if seek_time exist in url params*/
  if (seekIsActive) {
    var waitPlayer = setInterval(function () {
      if (window.pl3748 && window.pl3748.getState() === 'idle') {
        clearInterval(waitPlayer)
        pl3748.setVolume(0)
        pl3748.play(true);
        pl3748.on('firstFrame', function(e) {
          if (adver.ua.browser.name !== 'Safari') {
            //pl3748.setVolume(30) 
          }
          pl3748.seek(adver.qs.seek_time);
        })
      }
    }, 500);
  }
  
function initAdver() {
   adver.setParam('tags', window.ad_tags.split(',').map(function(value) { return value.trim(); }).join(','));
   adver.setParam('title', window.document.title.split(/\-HdZog\-/, 1)[0]);
   adver.init();
}
  
 if (window.location.href.indexOf('/videos/') < 0) { 
    initAdver();
 } else {
    document.addEventListener('loadTags', initAdver);
 } 
</script>
	<div id="app" class="app" role="main" :class="{'overlay': $root.isOverlay}"
		@click.self="$root.isOverlay = false; $root.modal = {};">
		<v-header inline-template>
			<header class="header" :class="{ 'header_fixed': $root.fixedHeader }" v-cloak>
				<div class="header__cookie" v-if="$root.show_cookie_policy == true" v-cloak>
					<div class="header__cookie-text">
						%% $t('component.cookies.text') %%
						<a href="/information/#cookies_policy" target="_blank">
							%% $t('component.cookies.link') %%
						</a>
					</div>
					<button class="btn" @click="$root.closeCookiePolicy()">OK</button>
				</div>

				<div class="header__container">
					<div class="header__wrapper">
						<v-burger class="header__burger"></v-burger>

						<a class="header__logo" href="/">
							<img src="/static/images/logo.svg?v=2" alt="logo">
						</a>

						<v-search class="header__search"></v-search>

						<div class="header__network" v-click-outside="hideNetworks">
							<div class="header__network-title">
								TXXX Networks
								<icon-arrow></icon-arrow>
							</div>
							<ul class="header__network-list">
																	<li class="header__network-item">
										<a class="header__network-link" 											href="https://txxx.com" target="_blank">TXXX</a>
									</li>
																	<li class="header__network-item">
										<a class="header__network-link" rel="nofollow noopener" 											href="https://hclips.com" target="_blank">HClips</a>
									</li>
																	<li class="header__network-item">
										<a class="header__network-link" rel="nofollow noopener" 											href="https://voyeurhit.com" target="_blank">VoyeurHit</a>
									</li>
																	<li class="header__network-item">
										<a class="header__network-link" rel="nofollow noopener" 											href="https://upornia.com" target="_blank">Upornia</a>
									</li>
																	<li class="header__network-item">
										<a class="header__network-link" rel="nofollow noopener" 											href="https://tporn.xxx" target="_blank">tPorn.xxx</a>
									</li>
																	<li class="header__network-item">
										<a class="header__network-link" rel="nofollow noopener" 											href="https://hotmovs.com" target="_blank">HotMovs</a>
									</li>
																	<li class="header__network-item">
										<a class="header__network-link" rel="nofollow noopener" 											href="https://pornq.com" target="_blank">PornQ</a>
									</li>
																	<li class="header__network-item">
										<a class="header__network-link" rel="nofollow noopener" 											href="https://vjav.com" target="_blank">VJAV</a>
									</li>
																	<li class="header__network-item">
										<a class="header__network-link" rel="nofollow noopener" 											href="https://100homemade.com" target="_blank">100HomeMade</a>
									</li>
																	<li class="header__network-item">
										<a class="header__network-link" rel="nofollow noopener" 											href="https://see.xxx" target="_blank">See.xxx</a>
									</li>
																	<li class="header__network-item">
										<a class="header__network-link" rel="nofollow noopener" 											href="https://pornl.com" target="_blank">PornL</a>
									</li>
																	<li class="header__network-item">
										<a class="header__network-link" rel="nofollow noopener" 											href="https://thegay.com" target="_blank">TheGay</a>
									</li>
																	<li class="header__network-item">
										<a class="header__network-link" rel="nofollow noopener" 											href="https://shemalez.com" target="_blank">ShemaleZ</a>
									</li>
															</ul>
						</div>

						<change-lang v-if="$root.device === 'desktop'" class="header__change-lang"></change-lang>

						<div v-if="$root.device === 'desktop'" class="header__userpanel">
							<div class="avatar btn_icons header__userpanel-btn" v-if="$root.user">
								<a class="wrapper" :href="'/members/'+$root.user.user_id">
									<div class="img" :title="$root.user.username.charAt(0) || ''"
										:class="{'no-avatar': !$root.user.avatar}" v-lazy="$root.user.avatar">
									</div>
									<span v-if="$root.device !== 'desktop'" class="name">%% $root.user.username %%</span>
								</a>
								<div class="dropdown">
									<div class="dropdown-user">
										<div class="dropdown-user__name">%% $root.user.username %%</div>
										<a href="/my_profile_edit/" class="link dropdown-user__link">%% $t('title.edit_profile') %%</a>
									</div>
									<a class="dropdown-item" :href="'/members/'+$root.user.user_id">%% $t('title.profile') %%</a>
									<a class="dropdown-item" :href="'/members/'+$root.user.user_id+'/favourite_videos/1'">%%
										$t('title.favourites') %%</a>
									<a class="dropdown-item" :href="'/members/'+$root.user.user_id+'/uploaded_videos/1'">%%
										$t('title.videos') %%</a>
									<a class="dropdown-item" v-if="$root.user" @click="$root.logout();">%% $t('title.logout') %%</a>
								</div>
							</div>

							<button type="button" class="header__userpanel-link header__userpanel-login" v-if="!$root.user"
								@click="showModal('login')">
								%% $t('title.login') %%
							</button>

							<button type="button" class="header__userpanel-link" v-if="!$root.user" @click="showModal('signup')">
								%% $t('title.registration') %%
							</button>

							<a href="/upload-video/" v-if="$root.device === 'desktop' && $root.user" v-auth
								class="btn_icons header__userpanel-btn">
								<icon-upload></icon-upload>
							</a>

							<a href="/my_messages/inbox/" v-if="$root.user" class="btn_icons header__userpanel-btn"
								:class="{ 'header__userpanel-btn-mail_unread': $root.unreadMessages}">
								<icon-mail></icon-mail>
							</a>
						</div>
					</div>

					<transition :name="transition" v-if="$root.device !== 'desktop'">
						<nav v-show="$root.isMenuOpen" class="header__nav" v-scroll-lock="$root.isMenuOpen">
							<div class="header__userpanel">
								<div class="avatar" v-if="$root.user">
									<a class="wrapper" :href="'/members/'+$root.user.user_id">
										<div class="img" :title="$root.user.username.charAt(0) || ''"
											:class="{'no-avatar': !$root.user.avatar}" v-lazy="$root.user.avatar">
										</div>
										<span v-if="$root.device !== 'desktop'" class="name">%% $root.user.username %%</span>
									</a>
								</div>

								<button type="button" class="header__userpanel-link header__userpanel-login" v-if="!$root.user"
									@click="showModal('login')">
									%% $t('title.login') %%
								</button>

								<button type="button" class="header__userpanel-link" v-if="!$root.user" @click="showModal('signup')">
									%% $t('title.registration') %%
								</button>

								<a href="/upload-video/" v-if="$root.device !== 'desktop' && $root.user" v-auth
									class="btn_icons header__upload">
									<icon-upload></icon-upload>
								</a>

								<a href="/my_messages/inbox/" v-if="$root.user" class="btn_icons"
									:class="{ 'header__userpanel-btn-mail_unread': $root.unreadMessages}">
									<icon-mail></icon-mail>
								</a>
							</div>

							<ul class="header__list">
								<li class="header__list-item">
									<a class="header__list-link" href="/latest-updates/">
										%% $t('component.header.nav.newest') %%
									</a>
								</li>
								<li class="header__list-item">
									<a class="header__list-link" href="/most-popular/">
										%% $t('component.header.nav.popular') %%
									</a>
								</li>
								<li class="header__list-item">
									<a class="header__list-link" href="/longest/">
										%% $t('component.header.nav.longest') %%
									</a>
								</li>
								<li class="header__list-item">
									<a class="header__list-link header__list-link-dropdown" @click.prevent="hiddenDropdown(1)"
										:class="{ 'header__list-link-dropdown-active': dropdownIndex === 1 }">
										%% $t('component.header.nav.categories') %%
										<svg width="6" height="3" viewBox="0 0 4 2" fill="none" xmlns="http://www.w3.org/2000/svg">
											<path d="M0 0L2 2L4 0H0Z" fill="#373A56" />
										</svg>
									</a>
									<ul v-show="dropdownIndex == 1" class="header__list header__list_lvl-2">
										<li v-for="(item, i) in $root.top.categories">
											<a :href="'/categories/'+item.dir+'/'">%% item.title %%</a>
										</li>
										<li>
											<a class="link" href="/categories">%% $t('title.all_categories') %%</a>
										</li>
									</ul>
								</li>
								<li class="header__list-item">
									<a class="header__list-link" :href="'/channels/'">
										%% $t('component.header.nav.channels') %%
									</a>
								</li>
								<li class="header__list-item">
									<a class="header__list-link" :href="'/models/'">
										%% $t('title.pornstars') %%
									</a>
								</li>
								<li class="header__list-item">
									<a class="header__list-link" :href="'/community/'">
										%% $t('title.community') %%
									</a>
								</li>
								<li class="header__list-item">
									<a class="header__list-link" :href="'/playlists/'">
										%% $t('title.playlists') %%
									</a>
								</li>
								<li class="header__list-item" v-if="$root.device !== 'desktop'">
									<a class="header__list-link header__list-link-dropdown" @click.prevent="hiddenDropdown(2)"
										:class="{ 'header__list-link-dropdown-active': dropdownIndex === 2 }">
										TXXX Networks
										<svg width="6" height="3" viewBox="0 0 4 2" fill="none" xmlns="http://www.w3.org/2000/svg">
											<path d="M0 0L2 2L4 0H0Z" fill="#373A56" />
										</svg>
									</a>
									<ul class="header__list header__list_lvl-2" v-show="dropdownIndex == 2">
																					<li>
												<a href="https://txxx.com" target="_blank">TXXX</a>
											</li>
																					<li>
												<a href="https://hclips.com" target="_blank">HClips</a>
											</li>
																					<li>
												<a href="https://voyeurhit.com" target="_blank">VoyeurHit</a>
											</li>
																					<li>
												<a href="https://upornia.com" target="_blank">Upornia</a>
											</li>
																					<li>
												<a href="https://tporn.xxx" target="_blank">tPorn.xxx</a>
											</li>
																					<li>
												<a href="https://hotmovs.com" target="_blank">HotMovs</a>
											</li>
																					<li>
												<a href="https://pornq.com" target="_blank">PornQ</a>
											</li>
																					<li>
												<a href="https://vjav.com" target="_blank">VJAV</a>
											</li>
																					<li>
												<a href="https://100homemade.com" target="_blank">100HomeMade</a>
											</li>
																					<li>
												<a href="https://see.xxx" target="_blank">See.xxx</a>
											</li>
																					<li>
												<a href="https://pornl.com" target="_blank">PornL</a>
											</li>
																					<li>
												<a href="https://thegay.com" target="_blank">TheGay</a>
											</li>
																					<li>
												<a href="https://shemalez.com" target="_blank">ShemaleZ</a>
											</li>
																			</ul>
								</li>
								<li class="header__list-item" v-if="$root.device !== 'desktop'">
									<a class="header__list-link header__list-link-dropdown" @click.prevent="hiddenDropdown(3)"
										:class="{ 'header__list-link-dropdown-active': dropdownIndex === 3 }">
										<i class="i flag" :class="'flag-'+$root.lang.currentLang" style="margin-right: 10px"></i>
										%% $root.lang.currentLang %%
										<svg width="6" height="3" viewBox="0 0 4 2" fill="none" xmlns="http://www.w3.org/2000/svg">
											<path d="M0 0L2 2L4 0H0Z" fill="#373A56" />
										</svg>
									</a>
									<ul v-show="dropdownIndex == 3" class="header__list header__list_lvl-2">
										<li v-for="(lang, key) in $root.lang.list" :key="key">
											<a @click="$root.setLocale(key)">
												<i class="i flag" :class="'flag-'+key" style="margin-right: 10px"></i>
												%% lang %%
											</a>
										</li>
									</ul>
								</li>
								<li class="header__list-item" v-if="$root.device !== 'desktop' && $root.user">
									<a class="header__list-link" @click="$root.logout();">
										%% $t('title.logout') %%
									</a>
								</li>
							</ul>
						</nav>
					</transition>
				</div>
			</header>
		</v-header>

		<tags-categories></tags-categories><v-amodule v-cloak>
  <template v-slot:script>
 	var getPoss = function() { 
    if (window.country_code) return !(country_code === 'IN' || country_code === 'PK')
      return true;
    }
	
    var skipTo = adver.qs.autoplay || seekIsActive;
    
    if (skipTo) {
		window.videoadvertising2 = {}
	}

  	var playerContainer = document.querySelector('.video-page__videoplayer-wrapper');

    adver('preroll', {
      adbEn: true,
      skipYTVpaid: adver.qs.promo === '31134' || adver.isPCO || (adver.isBravo && getPoss()),
      afterLoad: function() {
        //typeof window.x_8sW === 'function' && x_8sW();
      },
      player: {
        width: playerContainer.offsetWidth,
        height: playerContainer.offsetHeight
      },
      //skipoffset: adver.isPCO ? 10 : 5,
      afterLoad: function(data, loader) { 
        loader.setPlayerEvents('jw', pl3748);
      },
      forceSkip: skipTo
    });   
  </template>
</v-amodule>
<v-amodule v-cloak>
  <template v-slot:script>
    var isIOS = (/iPad|iPhone|iPod/.test(navigator.userAgent) || (navigator.platform === 'MacIntel' && navigator.maxTouchPoints > 1)) && !window.MSStream;

    adver('interstitial', {
      div: '.video-page__videoplayer-wrapper',
      size: '300x250',
      onClose: function(){if(typeof pl3748!='undefined')pl3748.play(true)},
      shouldStart: function() {
        return (
          (!isIOS || adver.qs.promo === '31134') 
          && !adver.isPCO 
          && !adver.isBravo 
          && !adver.qs.autoplay 
          && !adver.videoAutoplayed && adver.ua.is === 'mobile') || mz;
      },
      forceSkip: seekIsActive,
      contentLabel: adver.qs.promo === '31134'
    })
  </template>
</v-amodule>


<div class="content" v-if="!$root.error">
  <div class="overlay-hidden" :class="{ 'overlay overlay_z': $root.isMenuOpen && $root.device !== 'desktop' }"
       @click="$root.menuOpen"></div>
  <video-page inline-template>
    <div>
      <div class="content-block">
        <div class="video-page" v-cloak>
          <div class="video-page__wrapper">
            
            <div class="video-page__content">

              <div class="fiioed" v-if="$root.isMobile">
                <div class="banner">
                  <v-amodule v-cloak>
  <template v-slot:html>
	<div id="header_mobile" style="text-align: center;"></div>
  </template>
  
  <template v-slot:script>
    adver('header_mobile', {
      div: '#header_mobile'
    });
  </template>
</v-amodule>
                  <a class="text" rel="nofollow noopener"
                     href="https://clickadilla.com/?ref=tyH4jl5H&utm_source=hdzog&utm_content=desktop_underplayer"
                     target="_blank">AD</a>
                </div>
              </div>

              <div class="video-page__header" v-if="$root.device !== 'mobile'">
                <title-h1 style="margin-bottom:0" v-if="$root.device !== 'mobile'" :title="video.title"></title-h1>
              </div>

              <div class="video-page__row">
                <div class="video-page__videoplayer-content" :class="{ 'w-100' : $root.isMobile }">
                  <div class="video-page__videoplayer-wrapper">
                    <span ref="invideo_pause">
<div style="display:none">
<div>

<i class="oImefc">&times;</i>
<span>Advertisement</span>

<div data-nosnippet>
    <v-amodule v-cloak>
  <template v-slot:html>
    <div id="in_v"></div>
  </template>
  
  <template v-slot:script>
	adver('invideo', {div: '#in_v'});
  </template>
</v-amodule>
  </div>

<span class="oImefp"><i class="iRx9B"></i>Play video</span>

</div>
</div>
</span>                    <videoplayer-related :items="related.list" :loading="related.loading"></videoplayer-related>
                    <div class="video-page__videoplayer" id="videoplayer" ref="player">
                        <div style="position:absolute;top:0;left:0;width:100%;height:0;padding-bottom:56.25%">
                        <div style="position:absolute;width:100%;height:100%">
                          <div id="PLR"></div>
                        </div>
                        </div>
                    </div>
                  </div>
                  <div class="fiioed" v-if="video.title">
                    <template v-if="video.channel">
                      <div class="banner">
                        <a :href="video.channel.url" target="_blank" rel="nofollow noopener">
                          <img :src="video.channel.banner_img">
                        </a>
                        <div class="text">
                          Sponsored by
                          <a :href="video.channel.url" target="_blank">
                            %% video.channel.title %%
                          </a>
                        </div>
                      </div>
                    </template>
                    <template v-else>
                      <div class="banner" rel="nofollow noopener">
                        <v-amodule v-cloak>
  <template v-slot:html>
    <div id="und_ban" class="t2"></div>
  </template>
  <template v-slot:script>
    adver('underplayer', { div: '#und_ban' });
  </template>
</v-amodule>
                        <a class="text" rel="nofollow noopener"
                           href="https://clickadilla.com/?ref=tyH4jl5H&utm_source=hdzog&utm_content=desktop_underplayer"
                           target="_blank">AD</a>
                      </div>
                    </template>
                  </div>
                  <info-block :data="video" page="video" :is-see-more="isSeeMore">
                    <template v-slot:controllers>
                      <div class="info-block__controllers">
                        <div v-if="video.statistics" class="info-block__row">
                          <div class="info-block__controllers-wrapper">
                            <div class="info-block__controllers-control"
                                 @click="$root.vote('video', video.video_id, 1, video.statistics)"
                                 v-tooltip="$t('title.like')">
                              <icon-like></icon-like>
                              %% video.statistics.likes %%
                            </div>
                            <div class="info-block__controllers-control"
                                 @click="$root.vote('video', video.video_id, 0, video.statistics)"
                                 v-tooltip="$t('title.dislike')">
                              <icon-dislike></icon-dislike>
                              %% video.statistics.dislikes %%
                            </div>
                            <svg class="info-block__controllers-control-line" viewBox="0 0 100% 2" fill="none"
                                 xmlns="http://www.w3.org/2000/svg">
                              <rect width="100%" />
                              <rect class="info-block__controllers-control-line_active" :width="rating + '%'" />
                            </svg>
                          </div>
                          <div class="info-block__controllers-wrapper">
                            <div class="info-block__controllers-control info-block__controllers-control_static"
                                 v-tooltip="$t('title.views')">
                              <icon-eye></icon-eye>
                              %% video.statistics.viewed | reduce %%
                            </div>
                          </div>
                          <div v-if="video.statistics.comments" @click="scrollToComments"
                               class="info-block__controllers-wrapper">
                            <div class="info-block__controllers-control" v-tooltip="$t('title.comments')">
                              <icon-comments></icon-comments>
                              %% video.statistics.comments %%
                            </div>
                          </div>
                          <div v-if="$root.device === 'mobile'"
                               class="info-block__controllers-wrapper info-block__controllers-wrapper_mr-0">
                            <div @click="$root.showModal('AddTo', { title: video.title, id: video.video_id, url: url() })"
                                 class="info-block__controllers-control">
                              <icon-ellipsis style="margin-right: 0;"></icon-ellipsis>
                            </div>
                          </div>
                        </div>
                        <div v-if="video.statistics && $root.device !== 'mobile'" class="info-block__row">
                          <div @click="$root.showModal('ContactUs')"
                               class="info-block__controllers-control info-block__controllers-control_brn"
                               v-tooltip="$t('title.report')">
                            <icon-flag style="margin-right: 0;"></icon-flag>
                          </div>
                          <div @click="$root.showModal('Share', { id: video.video_id, url: url(), embed: true })"
                               class="info-block__controllers-control info-block__controllers-control_brn"
                               v-tooltip="$t('title.share')">
                            <icon-share style="margin-right: 0;"></icon-share>
                          </div>
                          <div @click="$root.showModal('AddToVideo', { title: video.title, id: video.video_id, url: url() })"
                               class="info-block__controllers-control" v-tooltip="$t('title.add_to')">
                            <icon-plus-add style="margin-right: 0;"></icon-plus-add>
                          </div>
                        </div>
                      </div>
                    </template>
                    <template v-slot:content-info>
                      <ul class="info-block__list">
                        <li v-if="video.user" class="info-block__list-item">
                          <span class="info-block__head"> %% $t('title.from') %% </span>
                          <a :href="'/members' + '/' + video.user.id" class="info-block__tag">%% video.user.username ||
                            video.title %%</a>
                        </li>
                        <li v-if="video.channel" class="info-block__list-item">
                          <span class="info-block__head"> %% $t('title.channel') %% </span>
                          <a :href="'/channel/' + video.channel.dir" class="info-block__tag">%% video.channel.title
                            %%</a>
                        </li>
                        <li v-if="video.post_date" class="info-block__list-item">
                          <span class="info-block__head"> %% $t('title.date_added') %% </span>
                          <span class="info-block__descr">%% $utils.parseDate(video.post_date) %%</span>
                        </li>
                        <li v-if="video.description" ref="descr" class="info-block__list-item">
                          <span class="info-block__head"> %% $t('title.description') %% </span>
                          <p class="info-block__descr">
                            %% video.description %%
                          </p>
                        </li>
                        <li v-if="video.categories" ref="cats" class="info-block__list-item"><span class="info-block__head"> %% $t('title.tags') %% </span><a v-for="(model, i) in video.models" :key="i" :href="'/models/' + model.dir"class="info-block__tag info-block__tag_icon"><icon-star></icon-star>%% model.title %%</a><a v-for="(tag, i) in video.categories" :key="i" :href="'/categories/' + tag.dir"class="info-block__tag">%% tag.title %%</a></li>
                      </ul>
                    </template>
                  </info-block>
                </div>
                <div class="video-page__banners" v-if="$root.device !== 'mobile' && !$root.isMobile"
                     rel="nofollow noopener">
                  <v-amodule v-cloak>
  <template v-slot:html>
    <div id="hdz_ntv_a"></div>
  </template> 
  <template v-slot:script>
    adver('ntv_a', {div: '#hdz_ntv_a'});
  </template> 
</v-amodule>
                  <v-amodule v-cloak>
  <template v-slot:html>
    <div id="hdz_ntv_b"></div>
  </template> 
  <template v-slot:script>
    adver('ntv_b', {div: '#hdz_ntv_b'});
  </template> 
</v-amodule>
                  <v-amodule v-cloak>
  <template v-slot:html>
    <div id="hdz_ntv_c"></div>
  </template> 
  <template v-slot:script>
    adver('ntv_c', {div: '#hdz_ntv_c'});
  </template> 
</v-amodule>
                  <a href="https://clickadilla.com/?ref=tyH4jl5H&utm_source=hdzog&utm_content=desktop_ntv"
                     rel="nofollow noopener" target="_blank" class="video-page__banners-link">AD</a>
                </div>
              </div>
            </div>

        </div>

        <div class="partners-wrap">
          <div class="video-page__wrapper">
            <div v-if="$root.isDonny" class="aa_label" v-cloak>Suggested for you</div>
            <partners></partners>
          </div>
        </div>

        <div class="video-page__wrapper">
            <div ref="related">
              <listing class="video-page__listing" type="Videos" :related="true" :items="related.list"
                       :loading="related.loading" :count="related.params.count" :error="related.error"
                       :params="related.params"></listing>
            </div>

            <div v-if="$root.isDonny" class="aa_label mt-5" v-cloak>Advertisement</div>

            <div class="video-page__nat" :class="$root.__nat_class"></div>
            <pagination class="pagination--related" :current="related.params.page" :params="related.params"
                        :total="related.total"
                        :pattern="'https://hdzog.com/videos/'+video.video_id+'/'+video.dir+'/#related'"
                        v-if="!related.error" name="pagination-related"></pagination>

          </div>
        </div>
      </div>

      <div class="footer-banners">
        <div class="footer-banners-container">
          <div class="footer-banner">
            <v-amodule v-cloak>
  <template v-slot:html>
    <div id="footer_1">
    </div>
  </template>
  
  <template v-slot:script>
    adver('footer_1', {
    	div: '#footer_1',
    	force: true
  	});
  </template>
</v-amodule>
          </div>
          <div class="footer-banner">
            <v-amodule v-cloak>
  <template v-slot:html>
    <div id="footer_2">
    </div>
  </template>
  
  <template v-slot:script>
    adver('footer_2', {
    	div: '#footer_2',
    	force: true
  	});
  </template>
</v-amodule>
          </div>
          <div class="footer-banner">
            <v-amodule v-cloak>
  <template v-slot:html>
    <div id="footer_3">
    </div>
  </template>
  
  <template v-slot:script>
    adver('footer_3', {
    	div: '#footer_3',
    	force: true
  	});
  </template>
</v-amodule>
          </div>
          <div class="footer-banner">
            <v-amodule v-cloak>
  <template v-slot:html>
    <div id="footer_4">
    </div>
  </template>
  
  <template v-slot:script>
    adver('footer_4', {
    	div: '#footer_4',
    	force: true
  	});
  </template>
</v-amodule>
          </div>
        </div>
      </div>

      <div class="content-block">
        <div class="video-page" v-cloak>
          <div class="video-page__wrapper">

            <comments object="video" :object_id="video.video_id" v-if="video.video_id" :sendevent="false">
              <template v-slot:header>
                <header class="listing__header">
                  %% $t('title.comments') %%
                  <span class="count">%% video.statistics.comments %%</span>
                </header>
              </template>
            </comments>
          </div>
        </div>
      </div>
    </div>
  </video-page>
</div>


<v-script>

</v-script>
			<modal :params="modal"></modal>
			<notifications :items="notifications"></notifications>
			<component-404 :code="$root.error" v-if="$root.error"></component-404>
			<v-footer inline-template>
			    <footer class="footer" v-cloak>
			        <div class="container">
			            <div class="footer__keywords">
			                <h2 v-for="(tag, i) in keywords" :key="i" class="footer__keyword-wrapper">
			                    <a class="footer__keyword" :href="'/search/1/?s='+tag">%% tag %%</a>
			                </h2>
			            </div>
			            <div class="footer__wrapper" v-cloak>
			                <div class="footer__column">
			                    <a class="footer__link" href="/sitemap">Sitemap</a>
			                    <a class="footer__link" href="/information/#terms" @click="scrollTop()">
			                        %% $t('component.footer.terms') %%
			                    </a>
			                    <a class="footer__link" href="/information/#policy" @click="scrollTop()">
			                        %% $t('component.footer.policy') %%
			                    </a>
			                    <a class="footer__link" href="/information/#dmca" @click="scrollTop()">DMCA</a>
			                    <a class="footer__link" href="/information/#2257" @click="scrollTop()">2257</a>
			                </div>
			                <div class="footer__column">
			                    <a class="footer__link" target="_blank" rel="nofollow noopener" href="https://tubecorporate.com/">
			                        %% $t('component.footer.partner') %%
			                    </a>
			                    <a class="footer__link" target="_blank" rel="nofollow noopener" href="https://tubecorporate.com/home/content">
			                        %% $t('component.footer.content') %%
			                    </a>
			                    <a class="footer__link" target="_blank" rel="nofollow noopener" href="https://tubecorporate.com/home/advertising">
			                        %% $t('component.footer.adv') %%
			                    </a>
			                </div>
			                <div class="footer__column">
			                    <a class="footer__link" target="_blank" rel="nofollow noopener" href="https://tubecup.uservoice.com/forums/919777-customer-feedback-for-hdzog">
			                        %% $t('component.footer.review') %%
			                    </a>
			                    <a class="footer__link" href="/information/#support">
			                        %% $t('title.support') %%
			                    </a>
			                </div>
			                <div class="footer__copyright" v-html="$t('component.footer.rta')">
			                </div>
			                <div class="footer__copyright" style="margin-top:0;">%% $t('component.footer.copyright') %% © 2014-2021 HDzog. %% $t('component.footer.all') %%.</div>
			            </div>
			    </footer>
			</v-footer>
			<v-amodule v-cloak>
  <template v-slot:script>
	var skipPop = false/* (adver.ua.is === 'mobile' && adver.isPCO) */;
    var isIOS = (/iPad|iPhone|iPod/.test(navigator.platform) || (navigator.platform === 'MacIntel' && navigator.maxTouchPoints > 1)) && !window.MSStream;
    if (isIOS) adver.ua.isMobile = true;

    if (!skipPop && !mz) {
      var bindSel = ['.jwplayer', '.listing__item_video'];
      var ignSel = [
        '.nopop',
        '#und_ban',
        '#ntv_a',
        '#ntv_b',
        '#ntv_c',
        '#iv_1',
        '.__nat_item'
      ];

      if (adver.ua.isChrome || adver.isPCO || seekIsActive) {
        ignSel = ignSel.concat([
          '.jwplayer',
          '.jw-svg-icon',
          '.jw-icon',
          '.jw-icon-inline',
          '.oImef',
          '.jw-slider-container',
          '.int_hsSJlay',
          '.jw-skip',
          '.jw-controls',
          '.jw-controlbar'
        ]);
      }

      adver.videoAutoplayed = false;
      var autoplayAfterPop = adver.localStore.get('atppop') === '1';
      if (autoplayAfterPop) {
        adver.videoAutoplayed = true;
        adver.localStore.add('atppop', 0);
        var waitPlayer = setInterval(function () {
          if (window.pl3748) {
            setTimeout(function () { // If it works don't touch
              pl3748.setVolume(0);
              pl3748.play(true);
            }, 1500);
            clearInterval(waitPlayer)
          }
        }, 500);
      }

      if (adver.isCWL && !adver.isPCO && !(adver.qs.promo === '31134' && adver.ua.is === 'mobile') && !seekIsActive) {
        bindSel = ['.jw-display-controls', '.int_hsSJlay', '.listing__item_video']
        ignSel = [];
      }

      if ((adver.qs.promo === '31134' || adver.isPCO) && adver.ua.is === 'mobile') {
        bindSel = ['.listing__item_video']
        ignSel = [];
      }

      adver('popunder', {
        zoneType: adver.qs.promo === '31134' ? 'exoclick' : undefined,
        interstitial: !(adver.qs.promo === '31134' || adver.isBravo || adver.isPCO || adver.isComWeb || adver.isMTC),
        proceedSSPResponse: function(resp) {
          if (!resp) return true;
          if (!resp.interstitial && !adver.qs.postest) return true;

          adver.postitial.run({
            frameSrc: resp.url,
            countClicks: 1,
            scrolling: true,
            bindTo: bindSel,
            ignoreTo: ignSel,
            cookieExpires: 240,
            shouldFire: function() {
              if (adver.qs.promo === '31134' || adver.isBravo || adver.isPCO || adver.isComWeb || adver.isMTC) return false;
              return true;
            } 
          });

          return false;
        },
        config: {
          bindTo: bindSel,
          ignoreTo: ignSel,
          mode: {
            newTab: true /* adver.isBravo || adver.ua.isMobile || ((adver.ua.isChrome || adver.isChrome) && adver.isPCO) */,
            under: true
          },
          limit: { maxHits: (adver.qs.promo === '31134' || adver.isBravo || adver.isPCO || adver.isMTC) ? 1 : 999999, perTime: 1440 }
        },
        popOpts: { nextHitTime: 3 },
        fuckGhostery: !!document.getElementById('ghostery-tracker-tally'),
        safePops: adver.qs.promo === '31134',
        shouldFire: function (element, opts) {
          if ((adver.isBravo || adver.qs.promo === '31134') && !!document.referrer && document.referrer.indexOf(location.origin) !== 0 && element && (element.className.indexOf('jw-icon') > -1 || element.className.indexOf('jw-icon-display') > -1)) localStorage.setItem('atppop', 1);
          return true;
        },
        disableAdditionalPop: adver.isBravo,
        resetAll: (adver.isCWL && document.referrer && !(document.referrer.indexOf(location.origin) === 0)) || 
            document.referrer.indexOf('promo=') !== -1 && location.href.indexOf('fr=') !== -1
      });
    }

if (mz) {
  var mzIgnore = adver.ua.is === 'desktop' && !isIOS ? [
    '.jw-controlbar',
    '.poper',
    'a[target=_blank]',
    'form',
    'input',
    '.footer-row'
  ] : [
    '.jwplayer',
    '.jw-svg-icon',
    '.jw-icon',
    '.jw-icon-inline',
    '.oImef',
    '.jw-slider-container',
    '.int_hsSJlay',
    '.jw-skip',
    '.jw-controls',
    '.jw-controlbar',
    '#int_hsSJ',
    '.mobile-header',
    '.pagination',
    '.modal',
    '.auth__wrapper',
    '.poper',
    'a[target=_blank]',
    '.dropdown-button',
    '.footer__title-dropdown',
    '#blm-block_wrapper',
    '.banner',
    'form',
    '.menu-button',
    '.context-menu-video-item',
    'input',
    '.dropdown',
    'button',
    '.header__list-link-dropdown',
    '.listing__item-ellipsis',
    '.info-block__row',
    '.info-block__info-btn',
    '.footer-row',
    '.video-page__user-subscribe',
    '.right__content',
    '.header__wrapper',
    '.listing-header-filter',
    '.context-menu-block',
    '.filters-button',
    '.filters-container',
    '.select-label',
    '.select-list'
  ];

  adver('popunder', {
    popOpts: {
      bindTo: ['*'],
      ignoreTo: mzIgnore,
      mode: {
        newTab: adver.ua.is !== 'desktop' || isIOS,
        under: true
      },
      perpage: 999999, 
      nextHitTime: 0.001
    },
    beforeOpen: function() {
      TCPop.reset();  
    }
  });

  if (adver.ua.is !== 'desktop' || isIOS) {
    adver('popunder', {
      popOpts: {
        storeName: 'mz-player-mobile',
        bindTo: [
          '.jwplayer',
          '.jw-svg-icon',
          '.jw-icon',
          '.jw-icon-inline',
          '.jw-reset',
          '.oImef',
          '.jw-slider-container',
          '.int_hsSJlay',
          '.jw-skip',
          '.jw-controls',
          '.jw-controlbar',
          '#int_hsSJ'
        ],
        ignoreTo: [],
        mode: {
          newTab: true,
          under: true
       },
       nextHitTime: 10
      }
    });
  }
}
  </template>
</v-amodule>
			<v-amodule v-cloak>
  <template v-slot:script>
    if (adver.isBravo || adver.qs.promo === '31134') {
      adver('instant_message', {
        contentLabel: adver.qs.promo === '31134'
      });
    } /* else if (adver.ua.is === 'mobile') {
      var adManager = document.createElement('script');
      adManager.src = "https://cst.cstwpush.com/static/adManager.js";
      adManager.setAttribute('data-admpid', 688);
      adver.waitUntil(0, function() {
        return document.body;
      },
      function() {
        document.body.appendChild(adManager);
      })
    } */
  </template>
</v-amodule>
			</div>
			<script>
window.__nat_class = (23 + Math.random()).toString(35).replace('.', '');
(function(n, a, t) {
	n = window.__nat_class;
	t = !adver.ua.isMobile;
	a = function(spot_id, size) {
		var box = document.createElement('div'),
			parent, type = 1,
			defElem, /* ][:pagination */ onPaginationReInit = function() {
				adver('native_ad', {
					type: 'json',
					p: {
						div: (document.createElement('div')),
						data: defPre(),
						onSuccess: onSuccessDef,
						onError: (function() {}),
						gifPrepare: 0,
						size: size,
					}
				});
			},
			onPaginationOn = false,
			page = 1,
			onPagination = function() {
				(parent = document.body.querySelector(parentSelector)) && (parent.appendChild(box));
			},
			ajaxPaginationStatus, ajaxPaginationOn, ajaxPagination = function() {
				if (ajaxPaginationOn) {
					return
				}
				ajaxPaginationOn = 1;
				window.addEventListener('pagination', init)
			},
			defData = [],
			defPre = function() {
				return defData.sort(function() {
					return (Math.random() - 0.5)
				}).slice(0, size).map(function(i) {
					var d = new Date(parseInt(i.duration) * 1e3);
					return {
						title: i.title,
						icon: i.screen,
						url: i.url + '?promo=21446',
						ad: d.toGMTString().split(' ')[4].split(':').filter(function(v, k) {
							if (!k && v == '00') {
								return false
							}
							return true
						}).join(':'),
						data: {
							id: i.video_id,
							tube: i.tube,
							sgroup_id: i.server_group_id
						}
					}
				});
			},
			/* cb list */ onSuccess = function(b) {
				if (!b || !b.box) {
					return
				}
				defElem && defElem.remove();
				box = b.box;
				defElem = box;
				onPagination();
			},
			onSuccessDef = function(b) {
				defElem && defElem.remove();
				box = b.box;
				defElem = box;
				onPagination();
				window['yaCounter49315045'] && yaCounter49315045.reachGoal('hdz_native_count_imp');
				box.querySelectorAll('a').forEach(function(a) {
					a.onclick = function() {
						window['yaCounter49315045'] && yaCounter49315045.reachGoal('hdz_native_count_click');
					}
				})
			},
			getGroupId = function() {
				var keyval = {
					gay: 67,
					she: 68
				};
				return keyval[adver.cookie.get('gender') || 'default'] || 66
			},
			durationPrepare = function(a) {
				if (!a) {
					return 'AD'
				}
				a = a.toString();
				(a = a.split(':').map(function(i, k) {
					return (parseInt(i, 10) || 0) * Math.pow(60, (1 - k))
				})).forEach(function(i, k, ar) {
					k && (ar[0] += i)
				});
				var date = new Date(a[0] * 1e3);
				return (date.getUTCHours() * 3600 + date.getUTCMinutes() * 60 + date.getUTCSeconds()).toString();
			},
			onError = function(e, a) {
				if (defData.length) {
					return onPaginationReInit()
				}
				if (location.pathname.indexOf('/videos/') === 0) {
					adver.ajax({
						url: 'https://native.tubecup.org/video/native/hdzog/' + (window.tubecupParams && window.tubecupParams.video_id || '') + '/?category_group_id1=' + getGroupId() + '&title=' + (window.tubecupParams && window.tubecupParams.title || ''),
						onSuccess: function(data) {
							try {
								defData = data = JSON.parse(data);
								onPaginationReInit()
							} catch (e) {}
						},
					})
				} else {
					adver.ajax({
						url: '//st.tubecup.org/related/country_top_dev.php?site=hclips&page=1&per_page=15&category_group_id=' + getGroupId() + '&country_code=' + ((window.constants && window.constants.country_code) ? window.constants.country_code : 'IE'),
						onSuccess: function(data) {
							try {
								data = JSON.parse(data);
								defData = data.map(function(i) {
									var url = i.url;
									i.url = '//hclips.com/videos/' + i.video_id + '/' + i.dir + '/';
									i.tube = 'hclips';
									i.screen = url + i.screen_main + '.jpg';
									i.duration = durationPrepare(i.duration);
									return i;
								});
								onPaginationReInit()
							} catch (e) {}
						},
					})
				}
			},
			/* data && init */ natInit = function() {
				adver('native_ad', {
					type: 'json',
					p: {
						div: document.createElement('div'),
						gifPrepare: 1,
						size: size,
						spot_id: spot_id,
						onError: onError,
						onSuccess: onSuccess,
					}
				})
			},
			selector = '',
			parentSelector = '',
			init = function() {
				var iBox = document.querySelector(parentSelector);
				iBox && iBox.classList.add('__nat--' + location.pathname.split('/')[1]);
				ajaxPaginationStatus && ajaxPagination();
				((adver.isAdBlock() || window.constants.user) ? onError : natInit)()
			},
			waitCount = 0,
			wait = function() {
				if (document.querySelector(selector)) {
					wait = function() {};
					return init();
				} else {
					waitCount++;
					if (waitCount < 50) {
						setTimeout(wait, 100)
					} else {
						wait = function() {};
						return init()
					}
				}
			},
			selector = '.listing__item_video';
		parentSelector = '.' + n;
		ajaxPaginationStatus = 1;
		return wait();
	};
	a(t ? 10 : 1364, 6)
})()
</script>

              <script src="/upd/20210420.073031.17625/assets/player.loader.js" async></script>
      

			<script src="/upd/20210419.143709.316024/static/js/chunk-vendors.js"></script>
			<script src="/upd/20210419.143709.169461/static/js/chunk-common.js"></script>
			<script src="/upd/20210419.143709.14283/static/js/video.js"></script>
			</body>

			</html>
<!-- HIT (at s4416, en|hdzog.com|video|0) -->